Requirements to run JScoreML


What you need:

  1. Internet Explorer 5, Netscape 4.7, or Netscape 6


  2. Java Plug-in 1.3 (1.3.0_01 for Netscape 6)

  3. Get the Java Plug-in 1.3

  4. QuickTime for Java 4.1

  5. Get QuickTime for Java 4.1

  6. JAXP 1.0.1 (Java API for XML Parsing)

  7. Get the JAXP 1.0

  8. Fughetta and Marl musical fonts

  9. Get Fughetta and Marl

    Screen Reader (Optional):
    If you wish to use a screen reader, you will need the following:

    (the screen reader is not functional at present, see problems encountered with JScoreML )

  10. Alpha Works' Java Speech API (for the screen reader)

  11. Get the Java Speech API

  12. IBM's ViaVoice Software package (for the screen reader)


Now place QuickTime's QTJava.zip , JAXP's jaxp.jar and parser.jar , and the optional Alpha Works ibmjs.jar files in your jre/1.3/lib/ext directory or place all the JAR files on your CLASSPATH.

Installing the fonts:

(On Windows): Save the marl.ttf and fughetta.ttf files on your local file system. Then go to Start->Settings->Control Panel->Fonts then click on File -> Install New Font and point to the font files.

NOTE: If you wish to save your score as a MIDI file on your local file system and/or use the screen reader functionality, pass the java run time parameter in your Java Plug-in (In Windows Start->Setting->Control Panel->Java Plug-in):

-Djava.security.policy=http://nide.snow.idrc.ocadu.ca/music/JScoreML/JScoreMLPolicy


SECURITY HAZARD NOTICE!

Make sure you delete this java run time parameter from your plug-in after you have finished using JScoreML. This policy file will have given applets unrestricted access to all your local files and folders!


Go and try JScoreML

Back to main JScoreML